Email Delivery Issues

Incident Report for BtcTurk | Global

Resolved

This incident has been resolved.
Posted Jul 21, 2026 - 13:25 UTC

Investigating

We are investigating an issue affecting email delivery for some users.

As a result, emails required for certain actions, including withdrawal confirmations and device verification, may be delayed or may not be received.

We are working to restore normal email delivery as quickly as possible and will provide further updates as they become available.
Posted Jul 21, 2026 - 08:46 UTC