Terra (LUNA) Network Delays (Deposits & Withdrawals)

Incident Report for BtcTurk | Global

Resolved

This incident has been resolved.
Posted Dec 15, 2025 - 07:01 UTC

Identified

LUNA deposit and withdrawal transactions are currently experiencing delays due to ongoing issues on the Terra (LUNA) network.
Our team is closely monitoring the situation and actively working to ensure transactions are completed as soon as the network stabilizes.
Posted Dec 12, 2025 - 09:09 UTC
This incident affected: Deposit Services (Terra (LUNA)) and Withdrawal Services (Terra (LUNA)).